Sender address rejected: Domain not found

  • 14 February 2024
  • 2 replies

I’m getting the following error suddenly for a customer when sending them emails. 

4.1.8 <>: Sender address rejected: Domain not found. Search the delivery provider suppression list for this email.


This has only started happening recently, possibly after DMARC implementation, but I’m not sure how this affected it, or how to resolve it. It doesn’t seem to be a wide spread issue as far as I can tell as other customer emails are delivering fine. All other previous emails for this customer were delivered successfully and this customer contacted us directly wondering why they hadn’t received this particular communication.

Can anyone point me in the right direction here?


Best answer by aaron 14 February 2024, 19:22

View original

2 replies

Userlevel 2

Hi @copleykj 👋

Aaron here from the support team. Thanks for reaching out to us here!

Jumping right in, the bounce reason that you’re seeing is indicative that there is an issue with your domain’s DNS settings. Sure enough, if we look at the DNS records for your domain, we can see that the MX and SPF (TXT) records are missing. They were there at one point, which allowed your domain to be verified, but they have since been removed by someone in your organization that has access to your DNS hosting account (Google Domains).


MX and SPF (TXT) missing:

DKIM (TXT) still present: 

So, to provide clarity, only checks for your DNS entries when you click “Verify domain”… there is not continuous polling to check that the records are still in place. You can get this issue sorted quickly by adding those MX and SPF (TXT) records back in Google Domains. The values for those records are:


MX Record:

  • Type: MX
  • Hostname:
  • Value: 10
  • Value: 10

SPF Record:

  • Type: TXT
  • Hostname:
  • Value: v=spf1 ~all

Once you get these records added back in Google Domains, your domain with be properly authenticated again and you should see these bounces resolved. Please don’t hesitate to reach out if you have any further questions!

Thank you for your help resolving this issue @aaron. Not sure how this happened, but very thankful for it to be resolved.

Just as a heads up, I had tried the “Verify domain” option under the settings for the sending domain and there were no errors returned, so there may be an issue with this function.

Thank you again