Suddenly some events not coming in through Segment

  • 23 April 2023
  • 1 reply



We’ve had a Segment > CIO setup going on for a while now and everything worked like a charm. Suddenly, some events (we don’t know exactly the extent of the issue) have stopped coming into CIO. The ones we’re aware of are ones that are called “auth:signup:admin” and “auth:signup:update”. We’ve tried sending them as test events from Segment to CIO as well, and we’re getting a positive response from CIO. Here’s the payload:
{ "body": {}, "headers": { "Access-Control-Allow-Origin": "*", "Alt-Svc": "h3=\":443\"; ma=2592000,h3-29=\":443\"; ma=2592000", "Cache-Control": "no-cache, no-store, must-revalidate, max-age=0", "Connection": "close", "Content-Length": "3", "Content-Type": "application/json; charset=utf-8", "Date": "Sun, 23 Apr 2023 21:29:53 GMT", "Status": "200 OK", "Via": "1.1 google" }, "statusCode": 200, "statusMessage": "OK" }

Nothing was changed on our end. Is it possible this is a new CIO bug?


Best answer by Ryan_cio 24 April 2023, 08:09

View original

1 reply

Userlevel 1

Hi Omer,

Thanks for reaching out. We don’t have other reports of this, so we’ll definitely need to take a closer look at why this might be happening for you.

First of all, it would be great to know that the data is being sent from Segment correctly. Do you have logging in that shows you the events missing being sent to If so, what response is received from I’m not an expert with, but looking at their documentation it sounds like you can use their “Event Delivery” feature to find some of this information:

Based on this we can find out if the event is being sent correctly from to start to narrow down if the issue is in how the information is being sent or how we’re receiving the information. Let us know what you find and we can continue looking into this for you!