Importing a csv via the interface

HI, i’m trying to upload an “import” csv file via the interface (before sending if via the api)

I got a cryptic error illegal base64 data at input byte 5


Do you have an idea on how to solve this ?

The file :


Best answer by Ryan_cio 23 June 2023, 10:26

View original

5 replies

Userlevel 2

Hi Benjamin,

Thanks for reaching out about this.

I tested this with the file that you shared, and I was able to successfully complete the import. I used “id” to identify people and had this mapped to the “_cio_customer_id” column in your CSV.


Is this the same way that you did this? If not, send through more details about how far you got in the import process and at which stage you received the error and we can test this out a little more.



That’s what i did.


I just saw that my original csv file contains the UTF-8 BOM, when removing it it work fine.

Userlevel 2

Hi Benjamin,

Ahh, that would do it - our import service doesn’t handle UTF-8 with BOM, so good find in your original file!

This is noted down on our end, so hopefully we can handle this better in the future.


Well, i tried it again, this time by creating the import via the api.

The file was not found because my server is not accessible.


But i saw that i can import a file inside my failed import, and getting the same error (no BOM in my file this time)

Same configuration for both import (same file too)

The one created via the api


And when creating if via the interface


Hi @Ryan_cio, i’m in the same situation than @benjaminl :

The import created by API failed with this message

And when I try to upload again the file manually, I have this error (same as @benjaminl and no BOM in the file)

But when I create a manual import using interface, and try to upload the same file, it succeeds.

Finally, I encounter this problem only in the production workspace. The same API upload run well in staging workspace.

Do you have an idea of the origin of this error ? Is it related to a workspace setting or parameter ?