Can't integrate the SDK into Objective-C based project

  • 12 November 2023
  • 4 replies

I got this issue when trying to integrate the SDK to Objective-C based project. I tried both SPM and Cocoapods, the same results. Any one knows how to resolve it? Thank you

Could not find module 'CioTracking' for target 'x86_64-apple-ios-simulator'; found: arm64-apple-ios-simulator, at: /Build/Products/Debug-iphonesimulator/CioTracking.swiftmodule


4 replies

Userlevel 2

Hey @hirophan 


We’ve seen that Xcode error a few times before with other iOS developers, and each case seems to have been solved in different ways:

We believe that this is likely more closely related to the specific device you're building on and/or your current xCode version/settings

  • Can you share what Mac and Mac OS are you using to build your app? (e.g. Are you developing on Apple Silicon or an Intel chip?)
  • What XCode version are you using? (You can get this by running xcodebuild -version in your CLI)

@Jordan Thanks for your suggestion but I tried all your links but nothing worked.

I’m using Macbook Pro, Mac OS 14.1.1 (23B81). Chip M2 Pro. XCode 15.0.1 (15A507)

Hey @hirophan 

If you've tried Jordan's suggestions and the error persists, please try the following:

  1. Delete the derived data.
  2. Restart Xcode.
  3. Reinstall the SDK (SPM/CocoaPods).

@aman Thanks for your reply. I tried to do it many times but got no luck.