Solved

include_foundations_css not found

  • 1 February 2024
  • 7 replies
  • 58 views

I create a new email layout template, based on one of the ones provided by customer.io. This new layout has the line

    {% include_foundation_css %}

Then, when in content editor (rich text), it shows this: 
 

 

And, it does not send it due to this. 

So, I tried this instead: 

<link href="https://cdnjs.cloudflare.com/ajax/libs/foundation-emails/2.2.1/foundation-emails.min.css" rel="stylesheet">

 Now, there are no errors => good. 

When I create an email, and send a test => all good. 

When i put it in a broadcast and send it for real => BAD - all is centered and bold. :(

I am sending via Sendgrid mail server. Is the test emails not sent from there? Is that the issue?


What is going on here? Am I missing something obvious?

 

  1. how come the provided way does not work?
  2. why is it all bold and centered when sending 
icon

Best answer by Byron 5 February 2024, 22:30

View original

7 replies

Userlevel 4

Hey @tomlun,

Would you be able to let us know which email template includes this: {% include_foundation_css %}? It appears that the email editor is identifying this as a missing Liquid attribute. 

It looks like you’re using a CSS stylesheet here. Would you mind trying to disable CSS pre-processing following the steps outlined here and see if this resolves the issue: https://customer.io/docs/journeys/disable-premailer/

Technically the email delivery service - whether it’s your Custom SMTP SendGrid or our default delivery service Mailgun shouldn’t impact this. How the email design is rendered is more dependent on the recipient’s email provider and this help document goes into this in a bit more detail: https://customer.io/docs/journeys/1-html-and-css/

Hopefully this helps to move you along in the right direction! 

 It happens for all pre-made templates available. Tried to disable, still the same - but this time - also the test email is badly formatted 

Should be: 
 

 

 

But comes out like this…

 

 

Userlevel 4

Hi @tomlun 

 

I’ve tested creating using one of our default layouts per your GIF and this is working as expected: 

 

Would you, by any chance, have made some of your own changes to the template? If so, then it could have been something within the layout HTML changes that you’ve made that is specifying for the font to be centralised.

Would you mind trying to use a brand new template email to see if the same issue persists?

The gif I pasted in the last response is out-of-the-box. No changes made. 

In your template, that you based on the “Big company annoucement”-base, do you have a reference to the {% include_foundation_css %} ?

Userlevel 2

Hi there,

 

This is Byron from the support team stepping in on this reply.

It looks like the issue you’re running into may be related to the version of liquid that is loaded into new templates for your workspace. We recently released a liquid upgrade, so new templates may be created with the Latest version of liquid, while older templates will run the Legacy version. You can find the version of the template by hovering over the Last saved on… timestamp in the editor and checking the Liquid Version.

 

I am able to replicate the error when loading a pre-built layout into a template running the Latest version, but the error isn’t there on the Legacy version. 

See here for instructions to downgrade, if necessary: https://customer.io/docs/journeys/liquid-upgrade/#how-to-downgrade

 

Thanks for bringing this to our attention. I’ll submit an issue for our engineering team to review.

OK, that solved it. Thanks. 

Userlevel 2

Hi @tomlun just wanted to update you that the team released a fix so that the existing templates are compatible with both versions of liquid. Thanks again for bringing this to our attention.

Reply