Solved

Unauthorized 401


Hey, 

I’m completely new here and didn’t find anything similar, any help is greatly appreciated.

So, yesterday I have created the token and whitelisted my IP, i was able to retrive the data using App Api and everything worked just fine. But this morning after several successul calls I’m getting 401 Unauthorized error. Has my token already expired? Or I’ve exceed some limits? 

Thank you

icon

Best answer by Ramy 25 May 2023, 11:23

View original

2 replies

Userlevel 1
Badge

Hi there!

 

Sure happy to help! When using our API, the 401 error could mean multiple things, that I’m happy to run through here:

  • If your account data resides in our EU Data Center, please make sure you are using the correct EU region's API documentation.
  • Please make sure you are using the correct credentials, as well as the correct Authentication method for the API endpoint you’re using.

    For context, there are separate keys for our Track API, and App API, as well as different methods for authentication listed here Track API Auth., App API Auth.

With that said, if the above checks do not fix the issue, please feel free to share more details with us on the API Request you’re sending, the endpoint you’re sending it to, as well as the exact error you’re receiving; and we’re more than happy to help you dig into that! :)

Hope that’s helpful!

Best,

Hey, thank you for reaching out. Turned out the IP address i whitelisted has changed. Solved

Reply