Solved

In App doesn't work on android release of react native

  • 19 July 2023
  • 3 replies
  • 70 views

Goa late. When debugging using the emulator, the inapp arrives normally, but when I generate the build release for android, the inapp does not arrive on the device. The user is being identified, the sdk was configured enabling the inapp, but even so in the release it doesn't work.
Would anyone know the reason?

icon

Best answer by Ryan_cio 21 July 2023, 10:03

View original

3 replies

Userlevel 2

Hi Daniel, 

Ryan here from the Technical Support team at Customer.io. I’m not sure exactly what could be happening here, but happy to jump into some troubleshooting with you.

  • What version of our React Native SDK are you currently using?
  • How are users identified in your app? Based on whether you’re using emailid, or cio_id, that’s the value you'll need to direct your messages to. The message won't be delivered if your site/app doesn’t identify people using the value you select.
  •  is there any in-app activity in your app's logs? You can enable logs by setting the configuration logLevel to debug. Here are the steps for doing this: https://customer.io/docs/sdk/react-native/updates-and-troubleshooting/troubleshooting/#capture-logs. Share the logs with us and we’ll be happy to take another look!

We’ll keep an eye out for this information Daniel and figure out a way for you to get these messages through!

Thanks,

Ryan

Hi Daniel, 

Ryan here from the Technical Support team at Customer.io. I’m not sure exactly what could be happening here, but happy to jump into some troubleshooting with you.

  • What version of our React Native SDK are you currently using?
  • How are users identified in your app? Based on whether you’re using emailid, or cio_id, that’s the value you'll need to direct your messages to. The message won't be delivered if your site/app doesn’t identify people using the value you select.
  •  is there any in-app activity in your app's logs? You can enable logs by setting the configuration logLevel to debug. Here are the steps for doing this: https://customer.io/docs/sdk/react-native/updates-and-troubleshooting/troubleshooting/#capture-logs. Share the logs with us and we’ll be happy to take another look!

We’ll keep an eye out for this information Daniel and figure out a way for you to get these messages through!

Thanks,

Ryan

 

378 / 5.000

Hi Ryan,

-My SDK is in version 3.1.3

-I am identifying my user with the following method: CustomerIO.identify(user?.email, { first_name: user?.profile?.firstName });

-About the logs, using the app with release.debug through the emulator, the inapp works normally, but when I use the apk file, and install it both on the emulator and on a physical device, the inapp does not arrive.

Userlevel 2

Hi Daniel,

I’m sure you’ve seen this already, but for others that happen upon this thread, we’ve identified a bug here, and we’re currently working on a fix for this (

)

Thanks for your patience as we get this fixed!

Ryan

Reply